BF2 1.5 Compatibility Hotfix available!

September 8th, 2009 | | Permalink

Note: This News Post has been updated. Please read the new instructions on how to install the updated hotfix. Guedoe encountered some hard drive errors during the creation of the first hotfix released yesterday so it basically destroyed the USI.17 installation of those who have installed yesterday’s version. We are very sorry and embarassed for this incident and hereby give you the updated files. All you have to do is reinstall USI 0.17 and then apply the small 0.2 meg hotfix.

After DICE recently released the BF2 1.5 Patch, many mods lost their compatibility to this new version. Other mod teams such as Project Reality, Forgotten Hope 2 and Sandbox already have released a hotfix to make their versions compatible with 1.5, and now it’s our turn to do so. We don’t have included anything new or fancy, we only changed the things that made USI crash when played with BF2 1.5.

So here we are with our updated hotfix. What it does: It patches the in your mods/usi.17/ folder and updates the mod description so it says 0.17d in the community tab.

Hotfix 0.17d – 0.2 MB
- download at
- download at

How to install:
– download the small executable file
– install it following the description
– play the game!

Make sure you have USI 0.17 and BF2 Patch 1.5 installed!

In case you own a server, you will have to install it on your local PC and then just upload the new and mod.desc to your server’s /mods/usi.17/ folder. Overwrite the existing files and you’re set. If you encounter any problems, feel free to let us know. As always, when you have bugs or feature requests, you can find the proper ways to report them on our homepage. Have fun playing USI 0.17 with BF2 1.5 compatibility, hope to see you soon.

– The USI Dev Team

Posted in Uncategorized | No Comments »

Intel says: Another new location

September 7th, 2009 | | Permalink

Hello everyone. We thought it was about time for another update on what’s going on behind the scenes. With BF2 patch 1.5 now being out and most mods requiring a compatibility update, we thought it would be a good idea to release a small hotfix for our fans so they can play US Intervention using BF2 1.5. As of now, USI 0.17 is not compatible with it, because some of our vehicles use mag sizes bigger than 1,000 and that doesn’t work too well with the 1.5 Patch.

Unfortunately, we have no idea when we will be releasing this small hotfix, but it shouldn’t take too long. The issues already are fixed and its really just a quick update to prevent the servers from crashing. Expect to hear from us regarding this subject pretty soon. But for now, let’s go on with this week’s update. Today we have some new map shots to show. The map we would like to present is new in the USI pool, and it’s called Insurgency. It was made by [EoD]Junglist, has been touched up by Guedoe and has some nice new gameplay elements in it. Of course, it also has full SP support.  You may also notice this map will have the Harrier from the Project Reality mod, modeled and textured by [R-DEV]Stigger and exported by [R-DEV]TrahnLee  More information on this beautiful asset later.

Please note that the pictures were taken in the editor so they are not available in the usual size and quality, but it should be enough to show you guys what this map is all about. You might spot some content that was not mentioned before, we will show you these in detail later on, so keep your eyes wide open for a new update on our website. See you guys soon.

insurgency_01 insurgency_02

insurgency_03 insurgency_04

insurgency_05 insurgency_06

insurgency_07 insurgency_08

Posted in Uncategorized | No Comments »

« Previous Entries